Unexpected third party system issue identified on 2026-04-29 at 22:30
Partial degradation
Acquiring 3D Secure for Visa only
2026-04-29 22:30 EEST
· 43 minutes
Updates
Resolved
April 29, 2026 · 23:13 EEST
Please note that the unexpected third party system issue was resolved on 29.04.2026 at 23:13 (EEST).
Affected services Acquiring 3D Secure for Visa only are available and are now operating normally.
The problem was on the route to the Visa Servers.
Investigating
April 29, 2026 · 22:30 EEST
← Back