Unexpected system issue identified on 2026-03-03 at 16:10
Partial degradation
Acquiring 3D Secure for Visa only
2026-03-03 16:10 EET
· 56 minutes
Updates
Resolved
March 3, 2026 · 17:06 EET
Please note that the unexpected issue was resolved on 03.03.2026 at 17:02 (EET).
Affected services Acquiring 3D Secure for Visa only are available and are now operating normally.
Investigating
March 3, 2026 · 17:06 EET
Affected services: Acquiring 3D Secure for Visa only .
The problem is under investigation!
Please stand by, next update will be in 30 minutes.
← Back